Results 1 to 11 of 11

Thread: Motor mount source NOT added (couldn't do it?)

  1. #1
    Join Date
    Dec 2007
    Location
    San Jose
    Posts
    920

    Default Motor mount source NOT added (couldn't do it?)

    Through Blatchat, I found that Caterhams use Jag-yoo-ahhr XKE motor mounts, available through Rock Auto for $5.30 American + tax and shipping. Other sources abound, but prices vary (they were higher). Just search for "xke engine mount" or "xke motor mount" or similar.
    edit -- I just checked, and the part is £16 +shipping on the Caterham parts site here, and it is out of stock.

    I tried to edit the Wiki to add this to the "Parts pages" in the sidebar myself, but that didn't fly.
    Last edited by Sean; July 19th, 2012 at 11:50 PM.
    | | Sean

  2. #2
    Join Date
    Sep 2003
    Location
    Newbury Park, CA
    Posts
    2,208

    Default

    XKE 1961-1971

    This part number ÜRO PARTS Part # C18556 from RockAuto. The photo looks correct. Is it the correct size?

    1961-1971XKE.jpg
    Last edited by Doug Liedblad; July 20th, 2012 at 09:25 AM.

  3. #3
    Join Date
    Dec 2007
    Location
    San Jose
    Posts
    920

    Default

    Quote Originally Posted by Doug Liedblad View Post
    XKE 1961-1971

    This part number ÜRO PARTS Part # C18556 from RockAuto. The photo looks correct. Is it the correct size?
    I'll let you know for sure in a few days - I just ordered a couple.

    edit -- They arrived yesterday, and appear to be the correct size. I plan to check the fit this weekend, if time permits.
    Last edited by Sean; July 25th, 2012 at 03:35 PM.
    | | Sean

  4. #4
    Join Date
    Sep 2003
    Location
    Newbury Park, CA
    Posts
    2,208

    Default

    Sean

    Did the motor mount fit OK?

    Thanks.

    Doug

  5. #5
    Join Date
    Dec 2007
    Location
    San Jose
    Posts
    920

    Default

    Sorry - forgot to update. Yes, it fit fine, although it did appear just slightly less robust than the Caterham-supplied original (which was failing after 5K miles). I drove to the dyno day with the replacement one installed, but I was carrying another as a spare. It is a slightly different shape in the rubber part, but all critical dimensions fit and it did not disintegrate on my drive.
    Three stars; Joe-Bob says check it out.
    Last edited by Sean; September 1st, 2012 at 06:51 PM.
    | | Sean

  6. #6
    Join Date
    Dec 2007
    Location
    San Jose
    Posts
    920

    Default

    Replacement motor mount on the right side of the car was failing, at a little over 5K miles after installing it - so, similar functionality to the original. Fortunately, I purchased three last time, so I had two spares remaining, and so installed one this evening - one left now. That will probably hold for the next 4,500 miles, but sometime before then I plan to get a couple of HD motor mounts for Caterham from Vibra-Technics in the U.K. They appear to be up to the job, or at least last longer than 5K miles (I hope).




    Edit -- Forgot to add: Rock Auto no longer carries the XKE ones.
    Last edited by Sean; May 13th, 2013 at 09:22 PM.
    | | Sean

  7. #7
    Join Date
    Sep 2008
    Location
    San Jose
    Posts
    309

    Default

    I just bought a couple of beck arnley mounts on Rock Auto for $5.54, but they appear to be the last 2 in stock.

    I also found this:

    http://www.amazon.com/URO-Parts-C185...N%3DB0066RVGF4

    They appear to be the same as above, if you can wait 2-4 months for delivery

  8. #8
    Join Date
    Dec 2007
    Location
    San Jose
    Posts
    920

    Default

    Quote Originally Posted by GWise View Post
    I also found this:

    http://www.amazon.com/URO-Parts-C185...N%3DB0066RVGF4

    They appear to be the same as above, if you can wait 2-4 months for delivery
    Same ÜRO part number, so gotta be the same part - good find!
    | | Sean

  9. #9
    Join Date
    Oct 2003
    Posts
    1,622

    Default

    Quote Originally Posted by Sean View Post
    Replacement motor mount on the right side of the car was failing, at a little over 5K miles after installing it - so, similar functionality to the original. Fortunately, I purchased three last time, so I had two spares remaining, and so installed one this evening - one left now. That will probably hold for the next 4,500 miles, but sometime before then I plan to get a couple of HD motor mounts for Caterham from Vibra-Technics in the U.K. They appear to be up to the job, or at least last longer than 5K miles (I hope).




    Edit -- Forgot to add: Rock Auto no longer carries the XKE ones.
    Hey Sean, did you try these? I realize £45.00 is a bunch but if they last more than the 5000+/- miles you're getting now they may be worth it, not least for peace of mind when on one of your frequent jaunts up and down the state.
    Last edited by moosetestbestanden; October 23rd, 2013 at 08:08 AM.
    Chris
    ------------
    A day you don't go a hundred is a day wasted

  10. #10
    Join Date
    Dec 2007
    Location
    San Jose
    Posts
    920

    Default

    Nah, I had it all f***ed up from the start. Just needed a big washer on top of the rubber mount. I'm sure these fancy-ass ones would work great, but 90 pounds + shipping in jolly olde bloody bleedin' is equal to about 150 bucks in real money American. I feel that's a bit much. If the mount combined with the B.F.W. fails anytime soon, then I may consider it, but for now, I'm happy w/ the cheap-o XKE mounts and a 30-cent washer from the local hardware store.
    | | Sean

  11. #11
    Join Date
    Oct 2003
    Posts
    1,622

    Default

    Agreed, totally (California speak). It appears that the little bell over the rubber is effectively a very fancy 30 cent washer - very very (very) fancy. No sale.:-)

    All of this talk has found me needing to have a look at mine now!
    Chris
    ------------
    A day you don't go a hundred is a day wasted

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Windshield Wiper Motor Mount
    By Michael Murphy in forum Questions and Answers
    Replies: 3
    Last Post: December 28th, 2011, 08:19 PM
  2. Rotor source added
    By magnusfeuer in forum Wiki7 discussion
    Replies: 1
    Last Post: April 24th, 2009, 06:20 PM
  3. Video Camera Mount....
    By BritishChris in forum Questions and Answers
    Replies: 3
    Last Post: July 13th, 2007, 08:31 PM
  4. Upper wishbone rear mount
    By jvr in forum Questions and Answers
    Replies: 5
    Last Post: June 7th, 2007, 05:47 PM
  5. Video Camera Mount
    By slomove in forum For Sale/Wanted
    Replies: 3
    Last Post: May 7th, 2004, 02:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •