Results 1 to 4 of 4

Thread: Torque - flywheel & pressure plate installation

  1. #1
    Join Date
    Jan 2004
    Location
    San Jose
    Posts
    213

    Default Torque - flywheel & pressure plate installation

    Installing my flywheel/clutch/pressure plate on the 2.3l Duratec today, and realized I'm not sure of the recommended torque values. A Google search turned up a post on the Focus Fanatics forum with this for the flywheel:
    "Torque bolts in sequence to 83 lb-ft (112 N-m)."

    ...and this for the pressure plate:
    "Tighten pressure plate bolts two (2) turns at a time in sequence and torque to 21 lb-ft (29 N-m)."

    I'm estimating those figures to be valid, but I'm apprehensive... Help much appreciated!

    edit: Also, should copper-based lubricant or threadlocker be used on either of these sets of bolts?
    edit2: Sent an e-mail to Ammo. He ought to know, but he's out until January 2nd. Damn, was hoping to get this done today.
    Last edited by Sean-og; December 22nd, 2007 at 12:36 PM.
    - Sean

  2. #2
    Join Date
    Sep 2003
    Location
    Seattle-ish, WA
    Posts
    353

    Default

    Attached is the Torque sheet for the Duratec I received from Raceline. They show the flywheel bolts at 85 lb-ft and the pressure plate at 22 lb-ft. For the life of me though I can't remember if I lubed the threads or used threadlocker. I would have done whatever the ARP instructions indicated. Hopefully someone else on here knows the answer.

    -John
    Attached Files Attached Files

  3. #3
    Join Date
    Jan 2004
    Location
    San Jose
    Posts
    213

    Default

    Well, through further searching, I have answered my own questions. Torque values above are correct, and use threadlocker. Thank you all for playing - here's Johnny to tell you what you've won.

    edit: Thanks John. Looks like we posted right about the same time. The "Here's Johnny to tell you what you've won" was not in reference to you (I can't type anywhere near that fast, even using both of my typin' fingers), but it is a bizarre coincidence.
    Last edited by Sean-og; December 22nd, 2007 at 08:26 PM.
    - Sean

  4. #4
    Join Date
    Jan 2004
    Location
    San Jose
    Posts
    213

    Default

    Got the flywheel bolts out of the bag today, ready to install, and there is some red stuff on about the first inch of threads. Now I'm apprehensive about applying Loctite to these threads until I find out what the red stuff is and if applying threadlocker on it is necessary, optional, or maybe harmful. :confused:

    Double damn!


    edit: Posted on Blatchat and got a reply - it is a thread sealer used to prevent oil from seeping past the threads and onto the clutch. Game on!
    Last edited by Sean-og; December 24th, 2007 at 07:45 AM.
    - Sean

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •